NEW: PaymentRequest PayID Registration/Deregistration & Payment Agreement hightened error rate

Incident Report for Azupay

Postmortem

Client Post Incident Advice

The incident we experienced last night impacted the PayID registration process for our paymentRequest product between 7pm and 9pm AEST, and some PayID registrations during this incident were delayed.

If you use our paymentRequest product and have a client who pays you via a payID, they may have been unable to complete a payment successfully against the PayID during this period.

Azupay successfully registered all PayIDs by 10PM AEST after the incident window, with the majority of impacted paymentRequests being registered by 9:20PM AEST.

You may need to contact customers who attempted payments during this period and request they re-attempt the payment if the paymentRequest is still in a WAITING status and you are expecting they should have paid by now.

As the PayIDs were not registered, the customer would have not been able to successfully look up the PayID in their banking portal, and no payment would have been attempted. 

You should contact impacted clients, let them know the PayID is now available for payment, and they should re-attempt it.

If end customers have any issues making payment to the registered PayID, please raise a request with our service desk at https://azupay.atlassian.net/servicedesk/customer/portal/3 for support.

Additional information on the root cause is still pending.

Posted Apr 16, 2026 - 12:22 AEST

Resolved

We have been monitoring the system and not seen any reoccurance of performance degradation, and the issue is resolved.

The issue occured upstream of Azupay and we are awaiting a post incident review with root cause. We will provide further details once they are available.
Posted Apr 16, 2026 - 09:13 AEST

Monitoring

We are observing that the error rate has recovered and services are now operating as expected.

We will continue to monitor the performance.

We will provide a root cause analysis when additional information is available.
Posted Apr 15, 2026 - 21:22 AEST

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2026 - 20:42 AEST

Identified

Our NPP banking partner has confirmed this issue and are investigating.

Payments against registered paymentRequests are not impacted.

We will be re-attempting registration of payIds for in flight payment requests.

We will provide updates as they become available.
Posted Apr 15, 2026 - 20:10 AEST

Investigating

We are aware of issues in payment request PayID registration and de-registration and payment agreement registrations and that these services are experiencing increased error rates.

We are currently investigating the impact and will provide a detailed update as soon as one becomes available.

Please do subscribe to our status page for the latest and most accurate information.

We apologise for the inconvenience caused.
Posted Apr 15, 2026 - 20:06 AEST
This incident affected: External NPP Network.